SpWebGames.com

SpWebGames Help Page

If you are having problems getting games to run, please note:

Most of the web games and apps run in any modern browser that supports HTML5.

Recent versions of Internet Explorer, Firefox, Chrome, Opera, Safari should all work. There is a known problem with IE versions less than 10.

Some apps require the Java plugin to be installed and enabled in your web browser. The latest, recommended version of Java is available as a free download from Oracle.


For other problems or to report bugs, please contact:
Contact Email Address or send in a comment.



©1994-2015 SP WebGames Ltd
Home... | About... | Comments...
Developed by: Steve Pugh
Contact Email: